WebSphere Issues

25/06/2013

Opening JSP in the Page Designer causes java.lang.StackOverflowError error in RAD

Filed under: Java, RAD — Ishtiaque @ 6:21 pm

I tried to open a JSP file in RAD7.5 and I got java.lang.StackOverflowError! RAD shutdown after this error and was throwing the same error while starting up. I did not want to make any change in JSP so my only goal was to some how start the RAD.

I resolved the issue by following steps:

1. Open workbench.xml in the folder \workspace_root\.metadata\.plugins\org.eclipse.ui.workbench

2. Search for JSP name in the file, it will get you to the following tag

<editor id=”com.ibm.etools.webedit.editor.HTMLEditor” name=mycompany.jsp” … </editor>

3. Comment out this tag as and try to start up the RAD. You may also consider to comment all the tags that contains JSP name but for only commenting the <editor tag resolved the RAD start-up issue.

<!– <editor id=”com.ibm.etools.webedit.editor.HTMLEditor” name=”AdvancedFee.jsp” … </editor> –>

The solution to this issue is documented on following IBM technote:

http://www-01.ibm.com/support/docview.wss?uid=swg21578258

Advertisements

Leave a Comment »

No comments yet.

RSS feed for comments on this post.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

%d bloggers like this: