WebSphere Issues

04/01/2012

cluster-setup taks failed with error code EJPCA3004E: ERROR: /CacheInstance:strategy/ not there in WebSphere Portal V6.0

Filed under: WAS, WCM, WebSphere Portal — Ishtiaque @ 2:09 am

If Dmgr and nodes are running on version 6.0.2.17 or higher, then adding new member into cluster will fail during the WPSconfig cluster-setup task due to WAS version 6.0.2.17 introduced changes to the scoping behavior of the application server. Portal scripts previously looked at the server scope for certain resources. This results in failures during WPSconfig cluster-setup for both the primary and the secondary node.

This issue was resolved by following steps:

1. Downgrading WAS version onto Dmgr and all nodes by uninstall WAS fixpack which was installed after fresh installation.

2. Install the portal fix PK38907 and PK68347 onto the new member.

3. Run WPSconfig cluster-setup task.

References:

http://www-01.ibm.com/support/docview.wss?uid=swg24015073

https://www-304.ibm.com/support/docview.wss?uid=swg1PK68347

http://groups.google.com/group/ibm.software.websphere.portal-server/browse_thread/thread/56c61658a417ddf3

Advertisements

Leave a Comment »

No comments yet.

RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

%d bloggers like this: